Browse Source

[Composer] Bump minimum PHP version to 7

- Remove paragonie/random_compat dependency
tags/2019.06^2
Hypolite Petovan 2 months ago
parent
commit
f2e5b29974
4 changed files with 4 additions and 5 deletions
  1. 1
    1
      INSTALL.md
  2. 1
    2
      composer.json
  3. 1
    1
      doc/Install.md
  4. 1
    1
      doc/de/Install.md

+ 1
- 1
INSTALL.md View File

@@ -29,7 +29,7 @@ is self-signed).
29 29
 ## 1. Requirements
30 30
 
31 31
 - Apache with mod-rewrite enabled and "Options All" so you can use a local .htaccess file
32
-- PHP 5.6.1+ (PHP 7.1+ recommended for performance and official support).
32
+- PHP 7+ (PHP 7.1+ recommended for performance and official support).
33 33
 	- PHP *command line* with `register_argc_argv = true` in php.ini
34 34
 	- curl, gd (with at least jpeg support), mysql, mbstring, xml, zip and openssl extensions
35 35
 	- Some form of email server or email gateway such that PHP mail() works

+ 1
- 2
composer.json View File

@@ -13,7 +13,7 @@
13 13
 		"issues": "https://github.com/friendica/friendica/issues"
14 14
 	},
15 15
 	"require": {
16
-		"php": ">=5.6.1",
16
+		"php": ">=7.0",
17 17
 		"ext-ctype": "*",
18 18
 		"ext-curl": "*",
19 19
 		"ext-dom": "*",
@@ -36,7 +36,6 @@
36 36
 		"mobiledetect/mobiledetectlib": "2.8.*",
37 37
 		"monolog/monolog": "^1.24",
38 38
 		"nikic/fast-route": "^1.3",
39
-		"paragonie/random_compat": "^2.0",
40 39
 		"pear/text_languagedetect": "1.*",
41 40
 		"psr/container": "^1.0",
42 41
 		"seld/cli-prompt": "^1.0",

+ 1
- 1
doc/Install.md View File

@@ -25,7 +25,7 @@ Requirements
25 25
 ---
26 26
 
27 27
 * Apache with mod-rewrite enabled and "Options All" so you can use a local .htaccess file
28
-* PHP 5.6.1+ (PHP 7.1+ is recommended for performance and official support)
28
+* PHP 7+ (PHP 7.1+ is recommended for performance and official support)
29 29
   * PHP *command line* access with register_argc_argv set to true in the php.ini file
30 30
   * Curl, GD, PDO, MySQLi, hash, xml, zip and OpenSSL extensions
31 31
   * The POSIX module of PHP needs to be activated (e.g. [RHEL, CentOS](http://www.bigsoft.co.uk/blog/index.php/2014/12/08/posix-php-commands-not-working-under-centos-7) have disabled it)

+ 1
- 1
doc/de/Install.md View File

@@ -28,7 +28,7 @@ Requirements
28 28
 ---
29 29
 
30 30
 * Apache mit einer aktiverten mod-rewrite-Funktion und dem Eintrag "Options All", so dass du die lokale .htaccess-Datei nutzen kannst
31
-* PHP  5.6.1+ (PHP 7.1+ wird für Performance und offiziellen Support empfohlen)
31
+* PHP  7+ (PHP 7.1+ wird für Performance und offiziellen Support empfohlen)
32 32
   * PHP *Kommandozeilen*-Zugang mit register_argc_argv auf "true" gesetzt in der php.ini-Datei
33 33
   * Curl, GD, PDO, MySQLi, xml, zip und OpenSSL-Erweiterung
34 34
   * Das POSIX Modul muss aktiviert sein ([CentOS, RHEL](http://www.bigsoft.co.uk/blog/index.php/2014/12/08/posix-php-commands-not-working-under-centos-7http://www.bigsoft.co.uk/blog/index.php/2014/12/08/posix-php-commands-not-working-under-centos-7) haben dies z.B. deaktiviert)

Loading…
Cancel
Save