Browse Source

moved check_db($via_worker) to Update::check($via_worker)

pull/5830/head
Philipp Holzer 2 years ago
parent
commit
ffbad2dc81
No known key found for this signature in database GPG Key ID: 517BE60E2CE5C8A5
3 changed files with 29 additions and 28 deletions
  1. +2
    -1
      bin/worker.php
  2. +0
    -27
      boot.php
  3. +27
    -0
      src/Core/Update.php

+ 2
- 1
bin/worker.php View File

@ -7,6 +7,7 @@
use Friendica\App;
use Friendica\Core\Config;
use Friendica\Core\Worker;
use Friendica\Core\Update;
// Get options
$shortopts = 'sn';
@ -30,7 +31,7 @@ require_once "boot.php";
$a = new App(dirname(__DIR__));
// Check the database structure and possibly fixes it
check_db(true);
Update::check(true);
// Quit when in maintenance
if (!$a->getMode()->has(App\Mode::MAINTENANCEDISABLED)) {


+ 0
- 27
boot.php View File

@ -413,33 +413,6 @@ function defaults() {
return $return;
}
/**
* @brief Function to check if request was an AJAX (xmlhttprequest) request.
*
* @param boolean $via_worker boolean Is the check run via the worker?
*/
function check_db($via_worker)
{
$build = Config::get('system', 'build');
if (empty($build)) {
Config::set('system', 'build', DB_UPDATE_VERSION - 1);
$build = DB_UPDATE_VERSION - 1;
}
// We don't support upgrading from very old versions anymore
if ($build < NEW_UPDATE_ROUTINE_VERSION) {
die('You try to update from a version prior to database version 1170. The direct upgrade path is not supported. Please update to version 3.5.4 before updating to this version.');
}
if ($build < DB_UPDATE_VERSION) {
// When we cannot execute the database update via the worker, we will do it directly
if (!Worker::add(PRIORITY_CRITICAL, 'DBUpdate') && $via_worker) {
Update::run();
}
}
}
/**
* @brief Automatic database updates
* @param object $a App


+ 27
- 0
src/Core/Update.php View File

@ -9,6 +9,33 @@ class Update
const SUCCESS = 0;
const FAILED = 1;
/**
* @brief Function to check if the Database structure needs an update.
*
* @param boolean $via_worker boolean Is the check run via the worker?
*/
public static function check($via_worker)
{
$build = Config::get('system', 'build');
if (empty($build)) {
Config::set('system', 'build', DB_UPDATE_VERSION - 1);
$build = DB_UPDATE_VERSION - 1;
}
// We don't support upgrading from very old versions anymore
if ($build < NEW_UPDATE_ROUTINE_VERSION) {
die('You try to update from a version prior to database version 1170. The direct upgrade path is not supported. Please update to version 3.5.4 before updating to this version.');
}
if ($build < DB_UPDATE_VERSION) {
// When we cannot execute the database update via the worker, we will do it directly
if (!Worker::add(PRIORITY_CRITICAL, 'DBUpdate') && $via_worker) {
self::run();
}
}
}
/**
* Automatic database updates
*/


Loading…
Cancel
Save