Browse Source

Merge pull request #9841 from MrPetovan/bug/fatal-errors

Fix wrong uses of DI::l10n() in Core\Update
pull/9849/head
Tobias Diekershoff 1 year ago committed by GitHub
parent
commit
81f53ff5ab
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
  1. 4
      src/Core/Update.php
  2. 1034
      view/lang/C/messages.po

4
src/Core/Update.php

@ -63,7 +63,7 @@ class Update
// We don't support upgrading from very old versions anymore
if ($build < NEW_TABLE_STRUCTURE_VERSION) {
$error = DI::l10n('Updates from version %s are not supported. Please update at least to version 2021,01 and wait until the postupdate finished version 1383.', $build);
$error = DI::l10n()->t('Updates from version %s are not supported. Please update at least to version 2021.01 and wait until the postupdate finished version 1383.', $build);
if (DI::mode()->getExecutor() == Mode::INDEX) {
die($error);
} else {
@ -74,7 +74,7 @@ class Update
// The postupdate has to completed version 1281 for the new post views to take over
$postupdate = DI::config()->get("system", "post_update_version");
if ($postupdate < NEW_TABLE_STRUCTURE_VERSION) {
$error = DI::l10n('Updates from postupdate version %s are not supported. Please update at least to version 2021,01 and wait until the postupdate finished version 1383.', $postupdate);
$error = DI::l10n()->t('Updates from postupdate version %s are not supported. Please update at least to version 2021.01 and wait until the postupdate finished version 1383.', $postupdate);
if (DI::mode()->getExecutor() == Mode::INDEX) {
die($error);
} else {

1034
view/lang/C/messages.po

File diff suppressed because it is too large Load Diff
Loading…
Cancel
Save