Browse Source

Bump minimum PHP version to 5.6.1

pull/5295/head
Hypolite Petovan 3 years ago
parent
commit
4e7471232e
  1. 2
      .travis.yml
  2. 2
      INSTALL.txt
  3. 2
      composer.json
  4. 4
      composer.lock
  5. 2
      doc/Install.md
  6. 2
      doc/de/Install.md

2
.travis.yml

@ -1,6 +1,6 @@
---
language: php
## Friendica supports PHP version >= 5.6
## Friendica supports PHP version >= 5.6.1
php:
- 5.6
- 7.0

2
INSTALL.txt

@ -32,7 +32,7 @@ link if your cert is self-signed).
- Apache with mod-rewrite enabled and "Options All" so you can use a
local .htaccess file
- PHP 5.6+ (PHP 7 recommended for performance).
- PHP 5.6.1+ (PHP 7 recommended for performance).
- PHP *command line* access with register_argc_argv set to true in the
php.ini file [or see 'poormancron' in section 8]

2
composer.json

@ -13,7 +13,7 @@
"issues": "https://github.com/friendica/friendica/issues"
},
"require": {
"php": ">5.6",
"php": ">=5.6.1",
"ext-xml": "*",
"asika/simple-console": "^1.0",
"divineomega/password_exposed": "^2.4",

4
composer.lock

@ -4,7 +4,7 @@
"Read more about it at https://getcomposer.org/doc/01-basic-usage.md#composer-lock-the-lock-file",
"This file is @generated automatically"
],
"content-hash": "4fcae78061a3eb72f91e4fa81e53af56",
"content-hash": "9e24971ae9340c5d9d4d4ca477d4ec29",
"packages": [
{
"name": "asika/simple-console",
@ -3582,7 +3582,7 @@
"prefer-stable": false,
"prefer-lowest": false,
"platform": {
"php": ">5.6",
"php": ">=5.6.1",
"ext-xml": "*"
},
"platform-dev": []

2
doc/Install.md

@ -27,7 +27,7 @@ Requirements
---
* Apache with mod-rewrite enabled and "Options All" so you can use a local .htaccess file
* PHP 5.6+ (PHP 7 is recommended for performance)
* PHP 5.6.1+ (PHP 7 is recommended for performance)
* PHP *command line* access with register_argc_argv set to true in the php.ini file
* Curl, GD, PDO, MySQLi, hash, xml, zip and OpenSSL extensions
* The POSIX module of PHP needs to be activated (e.g. [RHEL, CentOS](http://www.bigsoft.co.uk/blog/index.php/2014/12/08/posix-php-commands-not-working-under-centos-7) have disabled it)

2
doc/de/Install.md

@ -28,7 +28,7 @@ Requirements
---
* Apache mit einer aktiverten mod-rewrite-Funktion und dem Eintrag "Options All", so dass du die lokale .htaccess-Datei nutzen kannst
* PHP 5.6+ (PHP 7 ist aufgrund der Performance empfohlen)
* PHP 5.6.1+ (PHP 7 ist aufgrund der Performance empfohlen)
* PHP *Kommandozeilen*-Zugang mit register_argc_argv auf "true" gesetzt in der php.ini-Datei
* Curl, GD, PDO, MySQLi, xml, zip und OpenSSL-Erweiterung
* Das POSIX Modul muss aktiviert sein ([CentOS, RHEL](http://www.bigsoft.co.uk/blog/index.php/2014/12/08/posix-php-commands-not-working-under-centos-7http://www.bigsoft.co.uk/blog/index.php/2014/12/08/posix-php-commands-not-working-under-centos-7) haben dies z.B. deaktiviert)

Loading…
Cancel
Save